Resources

VNTANA Resource API – Rate Limits

API – Rate Limits

The VNTANA Admin API employs rate limiting to prevent abuse of server resources. These limits will be on an Organization basis, contact our support team to find out what your Organizations rate limit is.

The rate limits are handled using a token bucket system, with a certain amount of API calls allowed within a 60 second window. Once the limit has been reached, all API calls will be rejected with a 429 Too Many Requests response until the next refill.

The 60 second windows are not based around the last/first time a token is used. What this means is, if you make a call that utilizes a token and it has been 45 seconds since the last bucket refill, then it will still refill in 15 seconds, not 60 seconds after your new call.

Keeping Track of your Limit

When utilizing the API, it is recommended that you keep track of the remaining tokens in your rate limit and when they will refill so that your scripts or integrations can pause and pick up as needed. To assist with this, each response will contain headers that provide necessary information:

  • X-Rate-Limit-Remaining : this will indicate how many tokens are left in the current window
  • X-Rate-Limit-Reset-After-Seconds : this will indicate how many more seconds until the refill happens.

As mentioned above, a 429 status code will be returned when the limit is reached. This doesn’t mean that an error occurred, so your integration should be set up to pause based on the information provided in the headers, and retry/resume once the bucket refills.

On This Page

Accelerate Your
Digital Transformation

Learn how our platform can automate your 3D process.

Tap the magnifying glass to the left of your screen to search our resources.